天天看點

poj-1503-java大數相加

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0      

Sample Output

370370367037037036703703703670      
第一道java題,好開森;
import java.util.*;

import java.math.*;

import java.io.*;
public class Main{        //外面的Main必須大寫!

public static void main(String[] args){   //String  S大寫

Scanner cin= new Scanner(System.in);  
BigDecimal a=BigDecimal.valueOf(0);    //組合的函數名一般後個一定得大寫: BigInter  BigDecimal  valueOf(這前不大寫)  hasNext nextLine;
BigDecimal b=BigDecimal.valueOf(0);   //賦初值
String  str;
while(cin.hasNext())     //相當于!=EOF
{  
   str=cin.nextLine();    //下一行輸入nextLine
   if(str.equals("0"))    //equals
   {
       break;
   }
   else 
    {
        a=new BigDecimal(str); //強制轉化,把str轉化成大數
        b=b.add(a);     //b+a;
        
    }
    
}
System.out.println(b.toPlainString());   //println,是LN
                        //toPlainString 以字元形式輸出
}




}