天天看點

UVA 624 CD(01背包輸出)

Description

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

  • number of tracks on the CD. does not exceed 20
  • no track is longer than N minutes
  • tracks do not repeat
  • length of each track is expressed as an integer number
  • N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input 

Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output 

Set of tracks (and durations) which are the correct solutions and string `` sum:" and sum of duration times.

Sample Input 

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2
      

Sample Output 

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45
      

Miguel A. Revilla

2000-01-10

解題報告:題目大意就是講要将cd裡面歌轉存到錄音帶上,每首歌都有固定的時間。而錄音帶的存的總時間限制是固定的,問最多能存多長時間的歌,按照錄音帶中的順序來輸出具體存的歌。這題的處理也是01背包,不同的是需要輸出具體的。有一點就是v=w,是以可以直接用可達來才處理。然後用遞歸輸出路徑。

dp[i]表示存取時間為i的最後一首歌的時間。代碼如下:

#include <cstdio>
#include <cstring>
int t[22], dp[10005], vol, n, i, j, ans;
//dp[i]為達到i的前一個時間的值。
void print(int x) {
    if(x <= 0) return ;
    print(x - dp[x]);
    printf("%d ", dp[x]);
}
int main() {
    while (scanf("%d%d", &vol, &n) != EOF) {
        memset(dp, -1, sizeof(dp)), dp[0] = 0;
        ans = 0;
        for (i = 0; i < n; i ++) {
            scanf("%d", t + i);
            for (j = vol; j >= t[i]; j --) {
                if(dp[j-t[i]] != -1 && dp[j] == -1) {
                    dp[j] = t[i];
                    if (j > ans) ans = j;
                }
            }
        }
        print(ans);
        printf("sum:%d\n", ans);
    }
    return 0;
}
           

網上也有一些沒有按照要求輸出路勁的,但是也可以ac,用vis數組來标記路徑。

#include <cstdio>
#include <cstring>
int track[22], dp[10005], vis[21][10005], vol, n, i, j;

int main() {
    while (scanf("%d%d", &vol, &n) != EOF) {
        memset(dp, 0, sizeof(dp));
        memset(vis, 0, sizeof(vis));
        for (i = 0; i < n; i ++) {
            scanf("%d", track + i);
            for (j = vol; j >= track[i]; j --) {
                if(dp[j-track[i]] + track[i] > dp[j]) {
                    dp[j] = dp[j-track[i]] + track[i];
                    vis[i][j] = 1;
                }
            }
        }
        for (int i = n, j = vol; i >= 0; i --) {
            if(vis[i][j]) {
                printf("%d ", track[i]);
                j -= track[i];
            }
        }
        printf("sum:%d\n", dp[vol]);
    }
    return 0;
}