天天看點

poj-1012-約瑟夫問題

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0
      

Sample Output

5
30
題目大意:
有k個好人和k個壞人,從第一個人開始循環報數(即報到m後從1開始報),報到m的人被處死,要求全部的壞人都處死,好人留下,求出m。      
這個代碼就是有點慢,是以我打了個表


#include<iostream>
using namespace std;
int main()
{
    int k;
    while(cin>>k)
    {
        if(!k)
            break;

    int m=1;
    int ans[30]={0};
    for(int i=1;i<=k;i++)
    {
        ans[i]=(ans[i-1]+m-1)%(2*k-i+1);
        if(ans[i]<k)
        {
            i=0;m++;
        }
    }
    cout<<m<<endl;

    }

    return 0;
}

    }
    sort(yes,yes+n,cmp);

    sort(no,no+n,cmp);
    cout<<yes[n-1]<<" "<<no[n-1]<<endl;


    return 0;


}
      

  

#include<stdio.h>
int main()
{
	int k;
	int Joseph[14]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};
	while(scanf("%d",&k),k)
		printf("%d\n",Joseph[k]);
	return 0;
}
      

繼續閱讀