思科常用指令大全
1使用者模式
2:特權模式
enable
show vlan
show version
show interface
show mac-address-table
show running-config
copy running-config startup-config
3:全局配置模式
config terminal
hostname
enable password
ip default-gateway
4:接口配置模式
interface 端口
switchport mode trunk
5:line模式
line console 0
第2章 交換機的基本配置
1.配置主機
hostname
2.檢視交換機的配置
show running-config
使能密碼
enable password
加密儲存的使能密碼
enable secret
配置IP位址
interface vlan1
ip address
no shutdown
配置交換機的網關
ip default-gateway ipaddress
檢視交換機的MAC位址表
show mac-address-table
使用CDP協定
show cdp
show cdp interface
show cdp neighbors
show cdp neighbors detail
show cdp traffic
儲存與删除交換機配置
copy running-config startup-config
第三章:虛拟區域網路(VLAN)
VLAN的概述
VLAN是對連接配接在第2層交換機端口的網絡使用者的邏輯分段。
VLAN的作用:
1。廣播控制
2。安全(副産品)
3。帶寬利用
4。延遲
VLAN的種類
靜态:基于端口的VLAN
動态:基于MAC位址的VLAN
在交換機上配置靜态VLAN
建立VLAN
1。CONFIG TERMINAL
VLAN 2
NAME 2
2。特權模式下
VLAN DATABASE
VLAN 2 NAME 2
檢視VLAN
SHOW VLAN
删除VLAN
NO VLAN 2
驗證:SHOW VLAN BRIEF
在VLAN中添加端口
INTERFACE F0/2
INTERFACE RANGE F0/2 - 5
SWITCHPORT MODE ACCESS
SWITCHPORT ACCESS VLAN 2
VLAN配置執行個體
在交換機上添加VLAN2,VLAN3,VLAN3,端口範圍分别為1-4,5-8,9-12
這個執行個體的作用就是讓不同的VLAN的計算機之間的通信隔開。使達到減少廣播域範圍的作用。
一、交換機基本配置
(1) 步驟1 :配置主機名
switch>enable
switch#config t
switch(config)# hostname sw1
(2) 步驟2 :配置密碼
sw1(config)#enable secret cisco
sw1(config)#line vty 0 15
sw1(config-line)#password cisco
sw1(config-line)#login
(3)步驟3 :接口基本配置
sw1(config)#interface f0/1
sw1(config-if)#duplex (full|half|auto)
//duplex用來配置接口的雙工模式:full-全雙工 half-半雙工 auto-自動監測雙工的模式
sw1(config-if)#speed (10|100|1000|auto)
//speed指令用來配置交換機的接口速度 10-10mbps 100-100mbps 1000-1000mbps auto-自動監測接口速度
(4)配置管理位址
交換機允許被telnet ,這時需要在交換機上配置一個ip位址,這個位址是在vlan接口上配置的
sw1(config)#int vlan 1
sw1(config-if)#ip address 172.16.0.1 255.255.0.0
sw1(config-if)#no shutdown
sw1(config)#ip default-gateway 172.16.0.254
//以上是vlan 1接口上配置了管理位址,接在vlan 1 上的計算機可以直接進行telnet 該位址,為了其他網段的計算機也可以telnet 交換機,
我們在交換機上配置了預設網關。
(5) 儲存配置
sw1#copy running-config startup-config
二、交換機端口安全
(1)步驟1 :檢查r1的g0/0接口的mac位址
r1(config)#int g0/0
r1(config-if)#no shutdown
r1(config-if)#ip address 172.16.0.101 255.255.0.0
r1#show int g0/0 (檢視g0/0接口的mac位址)
(2)步驟2:配置交換機端口安全
sw1(config)#int f0/1
sw1(config-if)#shutdown
sw1(config-if)#switch mode access
//以上指令是把端口改為通路模式,即用來接入計算機
sw1(config-if)#switch port-security
//以上指令是打開交換機的端口安全功能
sw1(config-if)#switch port-security maximum 1
//以上指令是隻允許該端口下的mac條目最大數量為1,即隻允許一個裝置接入
sw1(config-if)#switch port-security violation (protect|shutdown|restrict)
//指令含義是:protect :當新的計算機接入時,如果該接口的mac條目超過最大數量,則這個新的計算機将無法接入,而原有的計算機不受影
響。
shutdown :當新的計算機接入時,如果該接口的mac條目超過最大數量,則該接口将會被關閉,則這個新的計算機和原有的計算機都無法接入,
需要管理者使用“no shutdown”指令重新打開。
restrict: 當新的計算機接入時,如果該接口的mac條目超過最大數量,則這個新的計算機可以接入,然而交換機将發送警告資訊。
sw1(config-if)#switch port-security mac-address 0019.5535.b828(r1的mac)
//允許r1路由器從f0/1接口接入。
sw1(config-if)#no shutdown
sw1(config)#int vlan 1
sw1(config-if)#no shutdown
sw1(config-if)#ip address 172.16.0.1 255.255.0.0
//以上是配置交換機的管理位址
(3) 步驟3:檢查mac位址表
sw1# show mac-address-table
(4)步驟4 模拟非法接入
r1# ping 172.16.0.1
通!
在r1上修改g0/0的mac位址為另個位址,模拟式另外一台裝置接入,
r1(config)#int g0/0
r1(config-if)#mac-address 12.12.12
過幾秒後,則在sw1 上出現提示f0/1接口被關閉
sw1#show int f0/1
sw1#show port-secutity
//以上指令是檢視端口安全的設定情況
三、交換機的密碼恢複
(1) 拔掉交換機電源,按住交換機前面面闆的mode鍵不放,接上電源,
(2) 輸入flash_init指令。
(3) 輸入load helper 指令
(4) 輸入dir flash:
//config.text 就是交換機的啟動配置檔案,和路由器的startup-config 類似。
(5) 輸入rename flash:config.text flash:config.old指令
//以上是将啟動配置檔案改名,這樣交換機啟動時就讀不到config.text了,進而沒有了密碼。
(6)輸入boot 指令引導系統,這時就不要在按住mode鍵了。
(7)當出現如下提示時,輸入n:
continue with the configuration dialog?:n
(8) 用enable 指令,進入特權模式,并将檔案config.old 該回config.text,指令如下。
sw1#rename flash:config.old flash:config.text
(9) 将原配置裝入記憶體,指令如下:
sw1#copy flash:config.text system:running-config
(10) 修改各個密碼:
sw1#config t
sw1(config)#enable secret cisco
sw1(config)#exit
(11) 将配置寫入nvram
sw1#copy running-config start-config
四、交換機的ios恢複
(1)把計算機的序列槽和交換機的console口連接配接好,用超級終端軟體連接配接上交換機,
(2)交換機開機後,執行以下指令
switch:flash_init
switch:load_helper
(3) 輸入複制指令:
switch:copy xmodem: flash:c2950-i6q412-mz.121-22.ea5a.bin
(4)傳送完畢後執行以下指令:
switch :boot
啟動系統
cisco指令大全
1.switch配置指令
(1)模式轉換指令
使用者模式----特權模式,使用指令"enable"
特權模式----全局配置模式,使用指令"config t"
全局配置模式----接口模式,使用指令"interface+接口類型+接口号"
全局配置模式----線控模式,使用指令"line+接口類型+接口号"
注:
使用者模式:檢視初始化的資訊.
特權模式:檢視所有資訊、調試、儲存配置資訊
全局模式:配置所有資訊、針對整個路由器或交換機的所有接口
接口模式:針對某一個接口的配置
線控模式:對路由器進行控制的接口配置
(2)配置指令
show running config 顯示所有的配置
show versin 顯示版本号和寄存器值
shut down 關閉接口
no shutdown 打開接口
ip add +ip位址 配置IP位址
secondary+IP位址 為接口配置第二個IP位址
show interface+接口類型+接口号 檢視接口管理性
show controllers interface 檢視接口是否有DCE電纜
show history 檢視曆史記錄
show terminal 檢視終端記錄大小
hostname+主機名 配置路由器或交換機的辨別
config memory 修改儲存在NVRAM中的啟動配置
exec timeout 0 0 設定控制台會話逾時為0
service password-encryptin 手工加密所有密碼
enable password +密碼 配置明文密碼
ena sec +密碼 配置密文密碼
line vty 0 4/15 進入telnet接口
password +密碼 配置telnet密碼
line aux 0 進入AUX接口
password +密碼 配置密碼
line con 0 進入CON接口
password +密碼 配置密碼
bandwidth+數字 配置帶寬
no ip address 删除已配置的IP位址
show startup config 檢視NVRAM中的配置資訊
copy run-config atartup config 儲存資訊到NVRAM
write 儲存資訊到NVRAM
erase startup-config 清除NVRAM中的配置資訊
show ip interface brief 檢視接口的谪要資訊
banner motd # +資訊 + # 配置路由器或交換機的描素資訊
de script ion+資訊 配置接口聽描素資訊
vlan database 進入VLAN資料庫模式
vlan +vlan号+ 名稱 建立VLAN
switchport access vlan +vlan号 為VLAN為配接口
interface vlan +vlan号 進入VLAN接口模式
ip add +ip位址 為VLAN配置管理IP位址
vtp+service/tracsparent/client 配置SW的VTP工作模式
vtp +domain+域名 配置SW的VTP域名
vtp +password +密碼 配置SW的密碼
switchport mode trunk 啟用中繼
no vlan +vlan号 删除VLAN
show spamming-tree vlan +vlan号 檢視VLA怕生成樹議
2.路由器配置指令
ip route+非直連網段+子網路遮罩+下一跳位址 配置靜态/預設路由
show ip route 檢視路由表
router rip 激活RIP協定
network +直連網段 釋出直連網段
interface lookback 0 激活邏輯接口
passive-interface +接口類型+接口号 配置接口為被動模式
debug ip +協定 動态檢視路由更新資訊
undebug all 關閉所有DEBUG資訊
router eigrp +as号 激活EIGRP路由協定
network +網段+子網路遮罩 釋出直連網段
show ip eigrp neighbors 檢視鄰居表
show ip eigrp topology 檢視拓撲表
show ip eigrp traffic 檢視發送包數量
router ospf +process-ID 激活OSPF協定
network+直連網段+area+區域号 釋出直連網段
show ip ospf 顯示OSPF的程序号和ROUTER-ID
encapsulation+封裝格式 更改封裝格式
no ip admain-lookup 關閉路由器的域名查找
ip routing 在三層交換機上啟用路由功能
show user 檢視SW的線上使用者
clear line +線路号 清除線路
3.三層交換機配置指令
配置一組二層端口
configure terminal 進入配置狀态
nterface range 進入組配置狀态
配置三層端口
configure terminal 進入配置狀态
interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-channel port-channel-number} 進入端口配置
狀态
no switchport 把實體端口變成三層口
ip address ip_address subnet_mask 配置IP位址和掩碼
no shutdown 激活端口
例:
Switch(config)# interface gigabitethernet0/2
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.20.135.21 255.255.255.0
Switch(config-if)# no shutdown
配置VLAN
configure terminal 進入配置狀态
vlan vlan-id 輸入一個VLAN号, 然後進入vlan配态,可以輸入一個新的VLAN号或舊的來進行修改。
name vlan-name 可選)輸入一個VLAN名,如果沒有配置VLAN名,預設的名字是VLAN号前面用0填滿的4位數,如VLAN0004是VLAN4的預設名字
mtu mtu-size (可選) 改變MTU大小
例
Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
或
Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
将端口配置設定給一個VLAN
configure terminal 進入配置狀态
interface interface-id 進入要配置設定的端口
switchport mode access 定義二層口
switchport access vlan vlan-id 把端口配置設定給某一VLAN
例
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#
fishwfk
2006-09-15, 16:10
配置VLAN trunk
configure terminal 進入配置狀态
interface interface-Id 進入端口配置狀态
switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封裝ISL 或 802.1Q 或自動協商
switchport mode {dynamic {auto | desirable} | trunk} 配置二層trunk模式。
dynamic auto—自動協商是否成為trunk
dynamic desirable—把端口設定為trunk如果對方端口是trunk, desirable, 配置Native VLAN(802.1q)
或自動模式,trunk—設定端口為強制的trunk方式,而不理會對方端口是否為trunk
switchport access vlan vlan-id 可選) 指定一個預設VLAN, 如果此端口不再是trunk
switchport trunk native vlan vlan-id 指定802.1Q native VLAN号
例:
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
定義TRUNK允許的VLAN
configure terminal子 進入配置狀态
interface interface-id 進入端口配置
switchport mode trunk 配置二層口為trunk
switchport trunk allowed vlan {add | all | except | remove} vlan-list可選) 配置trunk允許的VLAN.使用add, all, except, remove關
健字
no switchport trunk allowed vlan 允許所有VLAN通過
例
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
配置Native VLAN(802.1q)
configure terminal 進入配置狀态
interface interface-id 進入配置成802.1qtrunk的端口
switchport trunk native vlan vlan-Id 配置native VLAN号
no switchport trunk native vlan 端口配置指令回到預設的狀态
配置基于端口權值的負載均衡
configure terminal 進入Switch 1配置狀态
vtp domain domain-name 配置VTP域
vtp mode server 将Switch 1配置成VTP server.
show vtp status 驗證VTP的配置
show vlan 驗證VLAN
configure terminal 進入配置狀态
interface fastethernet 0/1 進入F0/1端口
switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封裝
switchport mode trunk 配置成trunk
show interfaces fastethernet0/1 switchport 驗證VLAN配置
按以上步驟對想要負載均衡的接口進行配置
在另一個交換機上進行此配置
show vlan 當trunk已經起來,在switch2上驗證已經學到相的vlan配置
configure terminal 在Switch 1上進入配置狀态
interface fastethernet0/1 進入要配置的端口
spanning-tree vlan 8 port-priority 10 将端口權值10賦與VLAN 8.
spanning-tree vlan 9 port-priority 10 将端口權值10賦與VLAN 9.
spanning-tree vlan 10 port-priority 10 将端口權值10賦與VLAN 10.
interface fastethernet0/2 進入F0/2
spanning-tree vlan 3 port-priority 10 将端口權值10賦與VLAN 3.
spanning-tree vlan 4 port-priority 10 将端口權值10賦與VLAN 4
spanning-tree vlan 5 port-priority 10 将端口權值10賦與VLAN 5
spanning-tree vlan 6 port-priority 10 将端口權值10賦與VLAN 10
end 退出
show running-config 驗證配置
copy running-config startup-config 儲存配置
配置STP路徑值的負載均衡
Trunk1走VLAN8-10,Trunk2走VLAN2-4
configure terminal 進入 Switch 1配置狀态
interface fastethernet 0/1 進入F0/1
switchport trunk encapsulation {isl | dot1q | negotiate}配置封裝
switchport mode trunk 配置Trunk,預設是ISL封裝
exit 退回
在F0/2口上重複2-4步驟
exit 退回
show running-config 驗證配置
show vlan驗證switch1 已經學到Vlan
configure terminal 進入配置狀态
interface fastethernet 0/1 進入F0/1
spanning-tree vlan 2 cost 30 設定Vlan2生成樹路徑值為30
spanning-tree vlan 3 cost 30 設定Vlan3生成樹路徑值為30
spanning-tree vlan 4 cost 30 設定Vlan4生成樹路徑值為30
end 退出
在switch1的F0/2上重複9-11步驟設定VLAN8,9,10生成樹路徑值為30
end 退出
show running-config 驗證配置
copy running-config startup-config 儲存配置
switch> ;按Ctrl+Break鍵
switch:reset ;或用boot指令
如果有配置檔案進入使用者模式,否則送出對話:
--- System Configuration Dialog ---
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Continue with configuration dialog? [yes/no]:y
Enter IP address:10.65.1.8
Enter IP netmask:255.255.0.0
Would you like to enter a default gateway address? [yes]:
IP address of default gateway:
Enter host name [Switch]:swa
The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.
Enter enable secret:aaa
Would you like to configure a Telnet password? [yes]:
Enter Telnet password:a
Would you like to enable as a cluster command switch? [no]:
The following configuration command was created:
......
Press RETURN to get started.
swa>en
password:aaa
swa#
2.路由器的初始化
路由器初始化與交換機類似,上電時按Ctrl+Break,進入ROM監控狀态
router> ;使用者模式,按Ctrl+Break
rommon>reset ;進入ROM監控狀态,複位引導
Continue with configuration dialog? [yes/no]:yes
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[ ]'.
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]:yes
Configuring global parameters:
Enter host name [router]:ra回車
The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password,
after entered, becomes encrypted in the configuration.
Enter enable secret:aaa回車
The enable password is used when you do not specify an
enable secret password,with some older software versions,
and some boot images.
Enter enable password:aa回車
The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password :a回車
Enter interface name used to connect to the management
network from the above interface summary:FastEthernet0/0回車
Configuring interface FastEthernet0/0:回車
Use the 100 Base-TX (RJ-45) connector? [yes]:回車
Operate in full-duplex mode? [no]:回車
Configure IP on this interface? [yes]:回車
IP address for this interface [ ]:10.1.1.1回車
Subnet mask for this interface [ ]:255.0.0.0回車
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]:回車
ra>
-
用指令行設定交換機和路由器的密碼和主機名
交換機和路由器的密碼和主機名的設定基本相同,在提問對話時,
回答n,則進入指令行的狀态。
先對交換機進行操作,輕按兩下SwitchA,出現:
switch>en ;第一次密碼為空
switch#conf t ;進入全局配置模式
switch(config)#hostname swa ;設定交換機名
swa(config)#enable secret aaa ;設定特權加密密碼為 aaa
swa(config)#enable password aax ;設定特權非密密碼為 aax
swa(config)#line console 0 ;進入控制台口(Rs232)
swa(config-line)#password aa ;設定登入密碼aa
swa(config-line)#login ;登入要求密碼驗證
swa(config-line)#line vty 0 4 ;進入虛拟終端virtual tty
swa(config-line)#password a ;設定登入密碼a
swa(config-line)#login ;登入要求密碼驗證
swa(config-line)#exit ;傳回上一層
swa(config)#exit ;傳回上一層
swa#sh run ;看配置資訊
swa#exit ;傳回指令
swa>en
password: ;請問輸入哪個口 (aaa)
secret是設定加密密碼,一般都使用這種密碼設定方式,它優先級高,
即沒設定secret密碼時,非加密密碼才有效。
路由器的設定與交換機類似,輕按兩下RouterA,進入使用者模式,例如:
router>en
router#conf t
router(config)#hostname roa
roa(config)#
......
......
與交換機相同,不現多述。
-
清除交換機密碼
清除交換機密碼,實際中是在開機時按住交換機上的mode按鈕,在
模拟軟體中按Ctrl+Break,進入ROM方式switch:。
配置檔案是flash:config.text,與nvarm:startup-configuse相同。
switch:flash_init
switch:dir flash:
switch:delete flash:config.text
switch:delete nvram:startup-configure
switch:boot 或
switch:reset
因為沒有了配置檔案,是以重新開機後會提示對話,要求進行配置。
有些情況下,最好用改名方法,修改密碼後現将原配置恢複,再重新設定
密碼後存盤。例如:
switch:flash_init
switch:rename flash:config.text config.bak
switch:boot
....
switch>en
switch#copy flash:config.bak running-configure
switch#conf t
switch(config)#en secret aaa
switch(config)#exit
switch#w 或
switch#copy run start
switch#reload
-
清除路由器密碼
路由器2621的配置檔案不讓删除和改名,需要采用設定寄存器開關的
方法實作。
實際當中是在上電時,按Ctrl+Break。在軟體模拟中,輕按兩下RouterA
進入終端模式,再按Ctrl+Break進入rommon>狀态,操作如下:
rommon> ;進入ROM監控狀态
rommon>confreg 0x2142 ;跳過配置檔案适用26xx 36xx 45xx
rommon>reset ;重新開機,等效于重開機
Continue with configuration dialog? [yes/no]:no
router>en
router#conf t
router(config)#enable secret bbb ;設定特權加密密碼為 bbb
router(config)#c onfig-register 0x2102 ;正常使用配置檔案
router(config)#exit
router#exit
router>
router>en
password:bbb
-
備份IOS和配置檔案
在實際工作中經常需要備份路由器的IOS和配置檔案,以備系統有問題時的
恢複。可以這樣操作:
router#dir nvram:
router#copy flash:c2621.bin tftp:
router#copy startup-config tftp:
router#