Kindergarten
Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.
The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input
2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output
題意描述:
程式代碼:
#include<stdio.h>
#include<string.h>
int e[210][210],match[210],book[210],n,m,k;
int dfs(int u);
int hungry();
int main()
{
int i,j,a,b,sum,q=1;
while(scanf("%d%d%d",&n,&m,&k)!=EOF)
{
if(n==0&&m==0&&k==0)
break;
//memset(e,0,sizeof(e));
memset(match,0,sizeof(match));
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
e[i][j]=1;
for(i=1;i<=k;i++)
{
scanf("%d%d",&a,&b);
e[a][b]=0;
}
sum=hungry();
printf("Case %d: %d\n",q++,n+m-sum);
}
return 0;
}
int dfs(int u)
{
int i;
for(i=1;i<=m;i++)
if(book[i]==0&&e[u][i]==1)
{
book[i]=1;
if(match[i]==0||dfs(match[i])==1)
{
match[i]=u;
return 1;
}
}
return 0;
}
int hungry()
{
int i,sum=0;
for(i=1;i<=n;i++)
{
memset(book,0,sizeof(book));
if(dfs(i)==1)
sum++;
}
return sum;
}