點選打開連結
Drainage Ditches
Time Limit: 1000MS | Memory Limit: 10000K |
Total Submissions: 49648 | Accepted: 18829 |
Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50
1号是源點,最後一個點m為彙點,求最大流,直接拿模闆
#include<stdio.h>
#include<stack>
#include<queue>
#include<string.h>
using namespace std;
#define max 300
int map[max][max];
int layer[max];
int m;
int source;
int target;
bool bfs()
{
queue<int> q;
q.push(source);
bool used[max] = {0};
memset(layer, 0, sizeof(layer));
used[source] = 1;
while(!q.empty())
{
int top = q.front();
q.pop();
int i;
if(map[top][target] > 0)
{
return true;
}
for(i = 1; i < m; i++)
{
if(map[top][i] > 0 && !used[i])
{
layer[i] = layer[top] + 1;
q.push(i);
used[i] = 1;
}
}
}
return false;
}
int dinic()
{
int max_flow = 0;
int prev[max] = {0};
int used[max] = {0};
while(bfs())
{
stack<int> s;
memset(prev, 0, sizeof(prev));
memset(used, 0, sizeof(used));
prev[source] = source;
s.push(source);
while(!s.empty())
{
int top = s.top();
if(map[top][target] > 0)
{
int j = top;
int min = map[top][target];
int mark = top;
while(prev[j] != j)
{
if(map[prev[j]][j] < min)
{
min = map[prev[j]][j];
mark = prev[j];
}
j = prev[j];
}
j = top;
map[top][target] -= min;
map[target][top] += min;
while(prev[j] != j)
{
map[prev[j]][j] -= min;
map[j][prev[j]] += min;
j = prev[j];
}
max_flow += min;
while(!s.empty() && s.top() != mark)
s.pop();
}
else
{
int i;
for(i = 1; i < m; i++)
{
if(map[top][i] > 0 && layer[i] == layer[top] + 1 && !used[i])
{
s.push(i);
used[i] = 1;
prev[i] = top;
break;
}
}
if(i == m)
s.pop();
}
}
}
return max_flow;
}
int main()
{
int n;
// freopen("in.txt", "r", stdin);
while(scanf("%d%d", &n, &m) != EOF)
{
memset(map, 0, sizeof(map));
int i;
int u, v, f;
for(i = 0; i < n; i++)
{
scanf("%d%d%d", &u, &v, &f);
map[u][v] += f;
}
source = 1;
target = m;
printf("%d\n", dinic());
}
return 0;
}