天天看點

HDU 1034 分糖果 (模拟題)

題目說的是一個分糖果的遊戲,n個學生圍成一圈,每個人手上有a[i]個糖果,每一輪遊戲開始時,學生手中的糖果都是偶數,他們都把自己手中一半的糖果分給他右邊的同學。分完後手中糖果數是奇數的,老師會給他一顆糖果。如果所有人手中的糖果數都一樣 遊戲結束。

    輸出總共進行了多少輪遊戲 還有最後學生手中的糖果數。

Problem Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0
        

Sample Output

15 14
17 22
4 8


   
    
     Hint
    
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

   
    
        
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000];
int main()
{
	int num,n,i,j,t,last;
	bool up;
	while(scanf("%d",&n)==1 && n) {
		for(i=1;i<=n;i++) scanf("%d",&a[i]);
		num=0;
		up=true;
		while(up) {
			up=false;
			last=a[1]/2;
			for(i=2;i<=n;i++) {
				t=a[i];
				a[i]=a[i]/2+last;
				if(a[i]&1) a[i]++;
				last=t/2;
			}
			a[1]=a[1]/2+last;
			if(a[1]&1) a[1]++;
			for(i=2;i<=n;i++) {
				if(a[i]!=a[i-1]) {
					up=true;
					break;
				}
			}
			num++;
		}
		printf("%d %d\n",num,a[1]);
	}
	return 0;
}