天天看點

Post Office - POJ 1160 dp

Post Office

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15376 Accepted: 8330

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50      

Sample Output

9      

題意:在v個村莊之間設立p個郵局,使得所有村莊到最近的郵局的距離和最小。

思路:先求出sum[i][j]為i到j的村莊之間如果設立一個郵局的距離最小和,sum[i][j]=sum[i][j-1]+num[j]-num[(i+j)/2];因為郵局設在中間肯定是距離最小的,偶數個的話,中間的兩個是一樣的。然後周遊k使得dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);表示到i個村莊設立j個郵局的最短距離。

AC代碼如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int sum[310][310],num[310],dp[310][40];
int main()
{ int i,j,k,v,p;
  scanf("%d%d",&v,&p);
  for(i=1;i<=v;i++)
   scanf("%d",&num[i]);
  for(i=1;i<=v;i++)
   for(j=i+1;j<=v;j++)
    sum[i][j]=sum[i][j-1]+num[j]-num[(i+j)/2];
  for(i=1;i<=v;i++)
  { dp[i][1]=sum[1][i];
    for(j=2;j<=p;j++)
    { dp[i][j]=dp[1][j-1]+sum[2][i];
      for(k=2;k<i;k++)
       dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);
    }
  }
  printf("%d\n",dp[v][p]);
}