天天看點

HDU 2844 Coins (多重背包) Coins

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13004    Accepted Submission(s): 5208

Problem Description Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.  

Input The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.  

Output For each test case output the answer on a single line.  

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
        

Sample Output

8
4
        

題目大意:你有n種硬币,讓你把這些硬币換成[1,m],有哪些可以做到.

比如  2 5 1 4 2 1 這兩種硬币可以換成 1,2,4,5,6 但是6大于5,是以不符合。是以有4種符合。

思路:這題思路很簡單,就是分别把為 i 屬于 1 - m 當做容量為i的背包,用多重背包做就好了,因為背包問題所有的政策都是目前容量最多能裝多少,最多就是裝滿,也就是如果能裝滿,那這個政策肯定可以裝滿。。。有一點不明白 為什麼網上的代碼都要分成多重背包跟完全背包呢。。。完全沒必要啊,因為第二個for已經限制了for(int j = sum; j >= v[i]; j--)這樣如果比背包容量大,直接跳過去了,不必擔心數組下表<0

網上普遍的多重+完全

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>

using namespace std ;

int a[110],c[110] ;
int dp[100010] ;
bool vis[100010] ;
int n, m;

void zeroOnepack(int cost,int weight)
{
    for(int i = m ; i >= cost ; i--)
    dp[i] = max(dp[i],dp[i-cost]+weight) ;
}
void completepack(int cost ,int weight)
{
    for(int i = cost ; i <= m ; i++)
    dp[i] = max(dp[i],dp[i-cost]+weight) ;
}
void multiplepack(int cost,int weight,int amount)
{
    if(cost * amount >= m)
    {
        completepack(cost,weight) ;
        return  ;
    }
    else
    {
        int k = 1 ;
        while(k < amount)
        {
            zeroOnepack(k*cost,k*weight) ;
            amount -= k ;
            k = k*2 ;
        }
        zeroOnepack(amount*cost,amount*weight) ;
    }
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(n == 0 && m==0) break ;
        for(int i = 0 ; i < n ; i++)
        scanf("%d",&a[i]) ;
        for(int j = 0 ; j < n ; j++)
        scanf("%d",&c[j]) ;
        memset(dp,0,sizeof(dp)) ;
        int cnt = 0 ;
        for(int i = 0 ; i < n ; i++)
        {
            multiplepack(a[i],a[i],c[i]) ;
        }
        for(int i = 1 ; i <= m ; i++)
        if(dp[i] == i)cnt++ ;
        printf("%d\n",cnt) ;
    }
    return 0 ;
}
           

直接多重轉成二進制01就行

#include <iostream>  
#include <algorithm>  
#include <queue>  
#include <math.h>  
#include <stdio.h>  
#include <string.h>  
using namespace std;  
int M[100010];  
int main()  
{  
    int A[110],C[110];  
    int n,m;  
    int i,j,k;  
    while(scanf("%d %d",&n,&m),n|m){  
       for(i=1;i<=n;i++)  
          scanf("%d",&A[i]);  
       for(i=1;i<=n;i++)  
          scanf("%d",&C[i]);  
         
       memset(M,0,sizeof(M));  
         
       int temp;  
       for(i=1;i<=n;i++)  
       {  
            k=1;  
          while(k<=C[i])  
          {  
            C[i]-=k;  
            temp=k*A[i];  
            for(j=m;j>=temp;j--)  
                M[j]=max(M[j],M[j-temp]+temp);  
            k=k<<1;  
          }  
          if(C[i]>0)   
          {  
            k=C[i];  
            temp=k*A[i];  
            for(j=m;j>=temp;j--)  
                 M[j]=max(M[j],M[j-temp]+temp);  
                    
          }  
       }  
        
      k=0;  
     for(i=1;i<=m;i++)  
        if(M[i]==i)  
           k++;  
      printf("%d\n",k);  
    }  
    return 0;  
}