Problem Description
某省調查鄉村交通狀況,得到的統計表中列出了任意兩村莊間的距離。省政府“暢通工程”的目标是使全省任何兩個村莊間都可以實作公路交通(但不一定有直接的公路相連,隻要能間接通過公路可達即可),并要求鋪設的公路總長度為最小。請計算最小的公路總長度。
Input
測試輸入包含若幹測試用例。每個測試用例的第1行給出村莊數目N ( < 100 );随後的N(N-1)/2行對應村莊間的距離,每行給出一對正整數,分别是兩個村莊的編号,以及此兩村莊間的距離。為簡單起見,村莊從1到N編号。
當N為0時,輸入結束,該用例不被處理。
Output
對每個測試用例,在1行裡輸出最小的公路總長度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
Sample Output
3
5
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<queue>
#include<map>
using namespace std;
#define ll long long
const int Inf=1e+9;
int n;
int mp[101][101];
bool vis[101];
int dist[101];
int Prim(int start)
{
int i,j;
for (i=1;i<=n;i++)
{
dist[i]=mp[start][i];
vis[i]=false;
}
dist[start]=0;
vis[start]=true;
int sum=0;
for (i=2;i<=n;i++)
{
int k;
int Min=Inf;
for (j=1;j<=n;j++)
if(!vis[j]&&dist[j]<Min)
{
Min=dist[j];
k=j;
}
vis[k]=true;
sum+=Min;
for (j=1;j<=n;j++)
if (!vis[j]&&dist[j]>mp[k][j])
dist[j]=mp[k][j];
}
return sum;
}
int main()
{
int i,m,a,b;
while (~scanf("%d",&n),n)
{
for (i=1;i<=n*(n-1)/2;i++)
{
scanf("%d%d%d",&a,&b,&m);
mp[a][b]=mp[b][a]=m;
}
for (i=1;i<=n;i++)
mp[i][i]=Inf;
printf("%d\n",Prim(1));
}
return 0;
}
下面是轉載的一篇,用的是克魯斯卡爾算法
http://blog.csdn.net/zcsylj/article/details/6561849
#include <iostream>
#include <algorithm>
using namespace std;
typedef struct Road
{
int c1, c2, cost;
}Road;
bool myCompare(const Road &a, const Road &b)
{
if(a.cost < b.cost)
return 1;
return 0;
}
Road road[5051];
int city[101];
int Find(int n)
{
if(city[n] == -1)
return n;
return city[n] = Find(city[n]);
}
bool Merge(int s1, int s2)
{
int r1 = Find(s1);
int r2 = Find(s2);
if(r1 == r2)
return 0;
if(r1 < r2)
city[r2] = r1;
else
city[r1] = r2;
return 1;
}
int main()
{
//freopen("input.txt", "r", stdin);
int n;
while(scanf("%d", &n) && n)
{
int m = n*(n-1)/2;
memset(city, -1, sizeof(city));
for(int i=0; i<m; ++i)
scanf("%d %d %d", &road[i].c1, &road[i].c2, &road[i].cost);
sort(road, road+m, myCompare);
int sum = 0, count = 0;
for(int i=0; i<m; ++i)
{
if(Merge(road[i].c1, road[i].c2))
{
count ++;
sum += road[i].cost;
}
if(count == n-1)
break;
}
printf("%d/n", sum);
}
return 0;
}