天天看點

HDU 3746 Cyclic Nacklace 【字元串循環節長度】Cyclic Nacklace

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7375    Accepted Submission(s): 3210

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

HDU 3746 Cyclic Nacklace 【字元串循環節長度】Cyclic Nacklace

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3 aaa abca abcde

Sample Output

0 2 5

Author

possessor WC

Source

HDU 3rd “Vegetable-Birds Cup” Programming Open Contest     

題意: 補最少的字元,讓字元串為一個循環的字元串

思路:求出字元串循環節的長度,我是沒想出來怎麼求,是網上看到有人說 為 len - Next[ len ],自己紙上模拟了了一下才覺得好像是這麼回事,的确想不出; 這裡的Next數組是 kmp算法裡面 getnext函數裡面求的一個數組,kmp我就不講了,這裡有一個結論就是  循環位元組的長度 = 字元總長度 - Next 【字元總長度】; 知道字元循環位元組的長度,對總長取餘就行了;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<cmath>
#include<algorithm>
#include<string>

using namespace std;

#define Maxn 100010
#define INF 0x3f3f3f3f

int Next[Maxn];
char a[Maxn];

void getNext (char ptr[]) {
    memset(Next,0,sizeof(Next));
    Next[0] = -1;
    int k = -1, j = 0, len = strlen(ptr);
    while (j < len) {
        if(k == -1 || ptr[k] == ptr[j] ) {
                ++j; ++k;
                Next[j] = k;
            } else k = Next[k];
    }
    int tmp = len - Next[len];
    if(len%tmp == 0 && tmp != len) printf("0\n");
    else printf("%d\n",tmp - len%tmp);
}

int main (void)
{
    int N;
   scanf("%d",&N);
        for (int i = 0; i < N; ++i) {
            scanf(" %s",a);
            getNext(a);
        }
    return 0;
}
           
kmp