Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
要求輸出最大子序列和max以及子序列頭尾a[begin],a[end]。
end可以在檢測到max的時候同時獲得。
為了達到O(N),begin用一個stack進行存儲(此處我用vector,也一樣),一遍掃過去可以獲得多個begin,這些begin對應不同end。
彈出棧頂的begin,直到begin<end。
/*2015.7.7*/
#include <iostream>
#include <vector>
#include <string>
#include <math.h>
using namespace std;
int main(){
int N;
cin>>N;
vector<int> a(N);
for(int i=0;i<N;i++)
cin>>a[i];
int sum=0;
int max=-2147483648;
int end=0;
vector<int> begin;
for(int i=0;i<N;i++){
if(sum<0){
sum=a[i];
begin.push_back(i);
}
else
sum+=a[i];
if(sum>max){
max=sum;
end=i;
}
}
if(max<0){
cout<<"0 "<<a[0]<<" "<<a[N-1];
return 0;
}
auto it=begin.end()-1;
while(*it>end)
it--;
cout<<max<<" "<<a[*it]<<" "<<a[end];
return 0;
}