點選打開連結
Red and BlackTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21053 Accepted Submission(s): 12830 Problem Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. Write a program to count the number of black tiles which he can reach by repeating the moves described above. Input The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set) Output For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). Sample Input Sample Output Source Asia 2004, Ehime (Japan), Japan Domestic |
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int w,h;
int v[25][25];
char str[25][25];
int ans=0;
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
void dfs(int x,int y)
{
v[x][y]=1;
for(int i=0;i<4;i++)
{
int xx=x+fx[i],yy=y+fy[i];
if(xx>=0&&xx<h&&yy>=0&&yy<w&&!v[xx][yy]&&str[xx][yy]=='.')
{
ans++;dfs(xx,yy);
}
}
}
int main()
{
while(~scanf("%d%d%*c",&w,&h),w,h)
{
ans=0;
for(int i=0;i<h;i++)
scanf("%s",str[i]);
memset(v,0,sizeof(v));
for(int i=0;i<h;i++)
for(int j=0;j<w;j++)
{
if(!v[i][j]&&str[i][j]=='@')
{
ans++;dfs(i,j);
}
}
printf("%d\n",ans);
}
return 0;
}