天天看點

HDU 1007 Quoit Design(最近點對問題:分治)Quoit Design

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45777    Accepted Submission(s): 11913

Problem Description Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.

In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.

Input The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.

Output For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
        

Sample Output

0.71
0.00
0.75
        

Author CHEN, Yue

Source ZJCPC2004

Recommend JGShining   |   We have carefully selected several similar problems for you:  1009 1011 1024 1018 1023 

題意:給你平面上的一堆點,然後求其中兩個點之間的最短距離。

題解:分治問題,最近點對問題。            距離最小的兩個點A、B,一定滿足條件:B必然是A按X或Y軸排序最短的點,故隻要分别按X、Y軸排序,分别            計算出每一點按X、Y軸最近的點的距離,取最小值即可。

AC代碼:

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct point
{
	double x,y;
}a[100001];
bool compare1(const point &a,const point &b)
{
	if(fabs(a.x-b.x)<1e-8)
        return a.y < b.y;
    return a.x<b.x;

}
bool compare2(const point &a,const point &b)
{
	if(fabs(a.y-b.y)<1e-8)
        return a.x < b.x;
    return a.y<b.y;

}

int main()
{
	int n;
	double k,s;
	while(~scanf("%d\n",&n)&&n)
	{
		k=11111111;
		for(int i=0;i<n;i++)
		{
			scanf("%lf %lf",&a[i].x,&a[i].y);
		}
		sort(a,a+n,compare1);
		for(int i=0;i<n-1;i++)
		{
			s=sqrt((a[i].x-a[i+1].x)*(a[i].x-a[i+1].x)+(a[i].y-a[i+1].y)*(a[i].y-a[i+1].y));
				if(k>s)
				k=s;
		}
		sort(a,a+n,compare2);
		for(int i=0;i<n-1;i++)
			{
				s=sqrt((a[i].x-a[i+1].x)*(a[i].x-a[i+1].x)+(a[i].y-a[i+1].y)*(a[i].y-a[i+1].y));
				if(k>s)
				k=s;
			}
       printf("%.2lf\n",k/2);

	}
	return 0;
}