天天看點

ZZUOJ-10436: easy problem

Description

給你一個數字N,N的範圍是1~1000000,求一個最小的正整數M,這個數字M的各個位的數字加上它本身之和恰好為N。當然,如果沒有解,輸出0。

Input

輸入資料由多組資料組成,每行由一個數字N組成(1<=N<=1000000)。

Output

對于每組資料,輸出僅一行包含一個整數M。如果對于每個N,存在最小的M,則輸出這個最小值。如果不存在這個最小的M,則輸出0。

Sample Input

216

121

2005

Sample Output

198

1979

鄭州大學第九屆ACM程式設計大賽試題。

簡單題,由于n<=1000000,是以n的各個位的數字之和最多是54(此時n為999999),是以,i隻要從(n > 60 ? n-60 : 0)開始循環,然後到n,是否存在滿足條件的數。

代碼如下:

/*
    Name: 10436: easy problem.
    Copyright: __X
    Author: long_long_ago
    Date: 17/12/15 15:36
    Description: 
    http://acm.zzu.edu.cn:8000/problem.php?id=10436
*/

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 1005

using namespace std;
int fun(int n)
{
    int ans = n;
    while(n)
    {
        ans += n%;
        n /= ;
    }
    return ans;
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int n, i;
    while(cin >> n)
    {
        i = (n >  ? n- : );
        for (; i < n; i++)
        {
            if (n == fun(i))
            {
                break;
            }
        }
        if (n == i)
        {
            cout << '0' << endl;
        }
        else
        {
            cout << i << endl;
        }
    }
    return ;
}