1002 A+B for Polynomials (25分)
This time, you are supposed to find A+BA+BA+B where AAA and BBB are two polynomials.Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
KKK N1N_1N1aN1a_{N_1}aN1N2N_2N2aN2a_{N_2}aN2 ... NKN_KNKaNKa_{N_K}aNK
where KKK is the number of nonzero terms in the polynomial, NiN_iNi and aNia_{N_i}aNi (i=1,2,⋯,Ki=1, 2, \cdots , Ki=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤101 \le K \le 101≤K≤10,0≤NK<⋯<N2<N1≤10000 \le N_K < \cdots < N_2 < N_1 \le 10000≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.Sample Input:
2 1 2.4 0 3.2 2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
可以看看我之前寫的 一進制多項式求和 / 積 ,内有數組表示法和改進的連結清單法。
這裡我偷了個懶,就用數組法寫的,代碼如下:
//
// Created by LittleCat on 2020/1/26.
//
#include <cstdio>
#define MAX_EXPONENTS 1000
int main() {
float a[MAX_EXPONENTS + 1] = {0}, b[MAX_EXPONENTS + 1] = {0};
int k;
/* 輸入第一個多項式 */
scanf("%d", &k);
for(int i = 0; i < k; i++) {
float coefficients;
int exponents;
scanf("%d", &exponents);
scanf("%f", &coefficients);
a[exponents] += coefficients;
}
/* 輸入第二個多項式 */
scanf("%d", &k);
for(int i = 0; i < k; i++) {
float coefficients;
int exponents;
scanf("%d", &exponents);
scanf("%f", &coefficients);
b[exponents] += coefficients;
}
int num = 0;
for(int i = 0; i <= MAX_EXPONENTS; i++) {
a[i] += b[i];
if(a[i] != 0)
num++;
}
printf("%d", num);
for(int i = MAX_EXPONENTS; i >= 0; i--) {
if(a[i] != 0)
printf(" %d %.1f", i, a[i]);
}
}
end
歡迎關注個人公衆号“雞翅程式設計”,這裡是認真且乖巧的碼農一枚,旨在用心寫好每一篇文章,平常會把筆記彙總成推送更新~