I Hate It
Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 65983 Accepted Submission(s): 25649
Problem Description 很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。
這讓很多學生很反感。
不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模拟老師的詢問。當然,老師有時候需要更新某位同學的成績。
Input 本題目包含多組測試,請處理到檔案結束。
在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表學生的數目和操作的數目。
學生ID編号分别從1編到N。
第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。
接下來有M行。每一行有一個字元 C (隻取'Q'或'U') ,和兩個正整數A,B。
當C為'Q'的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。
當C為'U'的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。
Output 對于每一次詢問操作,在一行裡面輸出最高成績。
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
Sample Output
5
6
5
9
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200005;
struct Node{
int l,r,m; //m存最大值
}node[maxn*4];
int a[maxn];
void build(int t,int l,int r) //建樹函數
{
node[t].l=l;
node[t].r=r;
if(l==r)
{
node[t].m=a[l];
return;
}
int mid=(l+r)/2;
build(t*2,l,mid);
build(t*2+1,mid+1,r);
node[t].m=max(node[t*2].m,node[t*2+1].m); //保持每個節點m的最大值
}
void update(int t,int n,int v) //更新函數
{
if(node[t].l==node[t].r)
{
node[t].m=v;
return;
}
if(n<=node[t*2].r) update(t*2,n,v);
else update(t*2+1,n,v);
node[t].m=max(node[t*2].m,node[t*2+1].m);
}
int find(int t,int l,int r)
{
if(l==node[t].l&&r==node[t].r) return node[t].m;
int s;
if(r<=node[t*2].r) s=find(t*2,l,r);
else if(l>=node[t*2+1].l) s=find(t*2+1,l,r);
else s=max(find(t*2,l,node[t*2].r),find(t*2+1,node[t*2+1].l,r));
return s;
}
int main()
{
int n,m,x1,x2;
char str[5];
while(~scanf("%d %d",&n,&m))
{
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
build(1,1,n); //建樹
while(m--)
{
scanf("%s %d %d",str,&x1,&x2);
if(str[0]=='Q') printf("%d\n",find(1,x1,x2));
else update(1,x1,x2);
}
}
return 0;
}