Legal or Not
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?
We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.
Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
Input The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
Output For each test case, print in one line the judgement of the messy relationship. If it is legal, output "YES", otherwise "NO".
Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
Sample Output
YES
NO
//題意:有師傅、徒弟關系,有些合法,有些非法,比如說1是2的師傅,2是3的師傅是合法的,但1是2的師傅,2是3的師傅,3是1的師傅就是非法的。題目還有句話是:還有如果1是2的師傅,2是3的師傅,那麼1也是3的師傅。大概就這個意思,如果合法輸出YES,不然輸出NO。
//思路:就是很裸的判斷圖裡是否存在環的問題。直接用個拓撲排序判斷,拓撲排序如果把一個圖裡所有點都周遊到了就無環,反之有環。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int MAX = 100 + 10;
int n, m;
vector<int>map[MAX];
int indegree[MAX];
bool toposort()
{
int cnt = 0;
queue<int>q;
for (int i = 0; i < n; i++)
{
if (!indegree[i])
q.push(i);
}
while (!q.empty())
{
int v = q.front();
q.pop();
for (int i = 0; i < map[v].size(); i++)
{
int u = map[v][i];
indegree[u]--;
if (!indegree[u])
q.push(u);
}
cnt++;
}
if (cnt == n)
return true;
else
return false;
}
int main()
{
while (scanf("%d%d", &n, &m), n)
{
int x, y;
memset(indegree, 0, sizeof(indegree));
for (int i = 0; i <= n; i++)
map[i].clear();
for (int i = 0; i < m; i++)
{
scanf("%d%d", &x, &y);
map[x].push_back(y);
indegree[y]++;
}
if (toposort())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}