天天看點

(HDU2052 C++) PicturePicture

Picture

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 37172 Accepted Submission(s): 18224

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line.

Sample Input

3 2

Sample Output

±–+

| |

| |

±–+

題意:輸入兩個數作為長方形的長和高,按照給定的樣例輸出一個長方形。

解題思路:

1、第一行和最後一行為一類,首項和尾項為“+”,其餘為“-”;

2、其餘各行為一類,首項和尾項為“+”,其餘為空格。

源代碼為:

#include<iostream>
using namespace std;
int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		for (int i = 1; i <= m+2; i++)
		{
			if (i == 1 || i == m+2)
			{
				for (int j = 1; j <= n + 2; j++)
				{
					if (j == 1)
						cout << "+";
					else if (j == (n + 2))
						cout << "+" << endl;
					else
						cout << "-";
				}
			}
			else
				for (int j = 1; j <= n+2; j++)
				{
					if (j == 1)
						cout << "|";
					else if (j == n + 2)
						cout << "|" << endl;
					else
						cout << " ";
				}
			
		}
		cout << endl;
	}
	return 0;
}