Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3
Source Greater New York 2000
Recommend We have carefully selected several similar problems for you: 1017 1016 1019 1014 1010 題意:本題要求的是給出一個整數,求該整數的各位數字之和; 分析:本題需注意的是,體重并沒給出整數的位數,故需要很容易想到字元數組,然後用一循環即可解出; 代碼:
#include<stdio.h>
#include<string.h>
int fun(int n)
{
int num=0,t,s;
while(n!=0)
{
t=n%10;
num+=t;
n=n/10;
}
return num;
}
int main()
{
int m,i,j,p;
int sum;
int a[100000];
char a1[100000];
while(~scanf("%s",a1))
{
if(strcmp(a1,"0")==0)
break;
p=strlen(a1);
for(i=0,j=p-1;j>=0;i++,j--)
a[j]=a1[i]-'0';
for(i=0,sum=0;i<p;i++)
sum+=a[i];
while(1)
{
m=fun(sum);
if(m<10)
break;
sum=m;
}
printf("%d\n",m);
}
return 0;
}