6-7 统计某类完全平方数 (20 分)
本题要求实现一个函数,判断任一给定整数
N
是否满足条件:它是完全平方数,又至少有两位数字相同,如144、676等。
函数接口定义:
int IsTheNumber ( const int N );
其中
N
是用户传入的参数。如果
N
满足条件,则该函数必须返回1,否则返回0。
裁判测试程序样例:
#include <stdio.h>
#include <math.h>
int IsTheNumber ( const int N );
int main()
{
int n1, n2, i, cnt;
scanf("%d %d", &n1, &n2);
cnt = 0;
for ( i=n1; i<=n2; i++ ) {
if ( IsTheNumber(i) )
cnt++;
}
printf("cnt = %d\n", cnt);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
105 500
输出样例:
cnt = 6
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <math.h>
int IsTheNumber(const int N);
int main()
{
int n1, n2, i, cnt;
scanf("%d %d", &n1, &n2);
cnt = 0;
for (i = n1; i <= n2; i++) {
if (IsTheNumber(i))
cnt++;
}
printf("cnt = %d\n", cnt);
return 0;
}
int IsTheNumber(const int N) {
/*
思路:
1.判断完全平方数:
将sqrt(N)强转为int型,即n = (int)sqrt(N);
如果最终n*n=N,则为完全平方数,否则不是。
2.判断是否至少两个数相同:
类似基数排序的思想,设一个数组Array[10],数组下标代表0~9号桶;
将N的每一位数进行剥离,然后依次与0~9号桶标号对比,和哪个桶标号相同,哪个桶的数值就加一;
一旦有一个桶数值等于2,即至少有两位数相同,满足条件,return 1。
*/
int n = (int)sqrt(N);
if (n*n == N) {
int Array[10] = { 0 };
int m = N;
while (m > 0) {
int tmp1 = m % 10;
for (int i = 0; i < 10; i++) {
if (tmp1 == i)
Array[i]++;
if (Array[i] == 2)
return 1;
}
m = m / 10;
}
return 0;//如果m=0还没有任意一个桶值为2则不满足条件
}
return 0;//任一条件不满足,return 0
}