天天看点

【杭电1081】To The MaxTo The Max

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11575    Accepted Submission(s): 5580

Problem Description Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

  Output Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
        

  Sample Output

15
        

Source Greater New York 2001   Recommend We have carefully selected several similar problems for you:   1024  1025  1080  1078  1074  题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1081

与杭电1559类似

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
int a[110][110],dp[110][110];
int main()
{
    int n,maxm;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
        {
            scanf("%d",&a[i][j]);
            if(i==1)
            dp[i][j]=a[i][j];
            else
            dp[i][j]=dp[i-1][j]+a[i][j];
        }
        }
        maxm=-INF;
        int sum=0,k,s;
        for(int i=1;i<=n;i++)
        {
            for(int j=i;j<=n;j++)
            {
                
                for(k=1;k<=n;k++)
                {   
                    sum=dp[j][k]-dp[i-1][k];
                    s=0;
                    for(int l=k;l<=n;l++)
                    {
                    s+=dp[j][l]-dp[i-1][l];
                    sum=max(sum,s);
                    }
                maxm=max(sum,maxm);
                }    
            }
        }
        printf("%d\n",maxm);
    }
    return 0;
}