天天看点

【杭电1114】完全背包

Piggy-Bank Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit  Status  Practice  HDU 1114 Appoint description:  System Crawler  (Aug 10, 2016 8:24:56 AM)

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4      

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.

This is impossible.



求最大价值:要求恰好装满背包,那么在初始化时除了dp[0]为0其它dp[1..V]均设为-∞

求最小价值:要求恰好装满背包,那么在初始化时除了dp[0]为0其它dp[1..V]均设为∞

题意:给你一个空的储蓄罐的重量E和装满硬币后的重量F,接下来一个整数N,表示硬币的总类,接下去

      N行,每行2个整数P和W,分别表示一枚硬币的价值和重量,输出储蓄罐里最少有多少元的硬币。
      如果重量不刚好则输出"This is impossible."

思路:此题属于完全背包的问题,不过此题要求的是最少的硬币,可以定义一个一维数组dp[],来存放当

      前最少的硬币的价值,由于重量要恰好相等,所以f[]要初始化为∞,如果dp[v]的值为∞,则输出

      "This is impossible.",否则输出"The minimum amount of money in the piggy-bank is dp[v]."



       
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
      
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 0xffffff
int dp[11000];
int main()
{
	int t,e,f,n;
	int p[11000],w[11000];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&e,&f);
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		scanf("%d%d",&p[i],&w[i]);
		dp[0]=0;//不装钱时 
		for(int i=1;i<=f-e;i++)
		dp[i]=inf;//初始化 
		for(int i=1;i<=n;i++)
		{
			for(int j=w[i];j<=f-e;j++)
			dp[j]=min(dp[j],dp[j-w[i]]+p[i]);
		}
		if(dp[f-e]!=inf)
		printf("The minimum amount of money in the piggy-bank is %d.\n",dp[f-e]);
		else
		printf("This is impossible.\n");
	}
	return 0;
}
           

继续阅读