题目:
Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.
Rule Find Replace-by 1. ban bab 2. baba be 3. ana any 4. ba b hind the g
To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of thefind string within the text by the replace-by string, then try to perform the same replacementagain on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for afind string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.
For example, suppose we start with the line
banana boat
and apply these rules. The sequence of transformations is shown below, where occurrences of afind string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.
Before After banana boat babana boat babana boat bababa boat bababa boat beba boat beba boat behind the goat
The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is thereplace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.
Both find and replace-by strings will be at most 80 characters long.Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.
The first test case in the sample input below corresponds to the example shown above.
sample input
4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
sample output
behind the goat
shoe or shop
题解:单词两个为一组,在给出的句子里从第一个单词开始替换,直到不能替换为止,开始替换第二个单词。。。替换结束输出。
#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
using namespace std;
string be[11], after[11], str, temp;
int main() {
int n, i, t, pos, length, len1, len2;
while (~scanf("%d", &n) && n) {
getchar();
temp = "";
str = "";
for (i = 0; i < n; i++) {
be[i] = "";
after[i] = "";
}
for (i = 0; i < n; i++) {
getline(cin, be[i]);
getline(cin, after[i]);
}
getline(cin, str);
for (t = 0; t < n; t++)
while (str.find(be[t]) != string::npos) {
temp = "";
length = str.size();
pos = str.find(be[t]);
len1 = be[t].size();
len2 = after[t].size();
for (i = 0; i < pos; i++)
temp += str[i];
temp += after[t];
for (i = pos + len1; i < length; i++)
temp += str[i];
str = temp;
}
cout << str << endl;
}
return 0;
}