天天看点

Big Event in HDU - HDU 1171 01背包 Big Event in HDU

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 22735    Accepted Submission(s): 7983

Problem Description Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1
        

Sample Output

20 10
40 40
  
  

        

题意:给你n组数,每组数代表V个人的有M个地方,然后让你分成两堆,使得人数差最小。

思路:01背包,优化是用二进制取代一个个去背包。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[3000010],value[60],num[60],num1,num2;
int main()
{ int n,m,i,j,k,sum,sum1;
  while(~scanf("%d",&n) && n>0)
  { sum=0;
    for(i=1;i<=n;i++)
    { scanf("%d%d",&value[i],&num[i]);
      sum+=value[i]*num[i];
    }
    sum1=sum;
    sum/=2;
    for(i=0;i<=sum;i++)
     dp[i]=0;
    for(i=1;i<=n;i++)
    { k=1;
      while(num[i]>=k)
      { m=k*value[i];
        for(j=sum;j>=m;j--)
         dp[j]=max(dp[j],dp[j-m]+m);
        num[i]-=k;
        k*=2;
        //printf("m %d\n",m);
      }
      if(num[i])
      { m=num[i]*value[i];
        for(j=sum;j>=m;j--)
         dp[j]=max(dp[j],dp[j-m]+m);
      }
    }
    //printf("sum %d\n",sum);
    printf("%d %d\n",sum1-dp[sum],dp[sum]);
  }
}