Aggressive cows
Time Limit: 1000MS | Memory Limit: 65536K |
Total Submissions: 16352 | Accepted: 7816 |
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C
* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3
Hint
OUTPUT DETAILS:
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.
Source
USACO 2005 February Gold
题解:n个位置,c头牛,将牛放入位置中,但是每两个牛不能相邻,要使牛之间的距离尽可能大,求这些距离之中的最小值
AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
int n,c;
ll x[100000+5];
int greed(ll s) //判断间隔s能否放下c头牛
{
int num=0,t=1;
ll p=x[1];
for(int i=2;i<=n;i++)
{
if(p+s<=x[i])
{
num++;
p=x[i];
}
}
if(num>=c-1)
return 1;
return 0;
}
int main()
{
while(~scanf("%d %ld",&n,&c))
{
for(int i=1;i<=n;i++)
cin>>x[i];
sort(x+1,x+n+1);
ll l=0,r=(x[n]-x[1])/(c-1),mid;//c头牛需要c-1个间隔
while(l<=r)//对间隔距离进行二分
{
mid=(l+r)/2;
if(greed(mid))
{
l=mid+1;
}
else
{
r=mid-1;
}
}
cout<<l-1<<endl;//这里不是mid,最后一次循环,mid=l=r,接下来如果满足条件,l-1就是结果,不满足条件,l不变因为l=mid,所以l不满足,l-1是结果
}
return 0;
}