天天看点

蒟蒻DP专题训练1--HDU2955 Robberies

       啊啊马上要面对研究生机试了,本蒟蒻打算每周一个专题训练。我感觉自己DP还是不行,实在是脑子转不过来不知道怎么推转移方程2333。

       今天写的第一题就是比较坑的DP,HDU2955。此题的坑点在于:

      1、误认为投银行被抓的概率是求和,事实上题目里面有很明显的提示说每次偷银行是独立的,说明是用乘法定律。

      2、dp的迭代方向是逆序的。看过很多人的博客都是直接写逆序迭代,但是本人比较笨不懂为什么不可以用正序迭代。但是dp是不可以有覆盖的,也就是说在转移方程里不可以出现原有的dp数组后来被更新的现象,否则前面部分的推导就是错误的。

     原题如下:

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 23427    Accepted Submission(s): 8644

Problem Description The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

蒟蒻DP专题训练1--HDU2955 Robberies

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.  

Input The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .  

Output For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.  

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
        

Sample Output

2
4
6
  
  

        

      AC代码如下:

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
double dp[10010];//dp[i]表示偷取i数量的钱的最大逃脱概率 
int v[110]; 
double tp[110];
int main()
{
	int n;
	scanf("%d", &n);
	while(n--)
	{
		double p0;
		int t, sum = 0;
		scanf("%lf %d", &p0, &t);
		for(int i = 1; i <= t; i++)
		{
			scanf("%d %lf", &v[i], &tp[i]);
			sum += v[i];
		}
		
		memset(dp, 0, sizeof(dp));
		dp[0] = 1;//什么也不偷逃脱概率为1 
		   
		for(int i = t; i >= 1; i--)
		{
			for(int j = sum; j >= v[i]; j--)
			{
				dp[j] = max(dp[j], dp[j-v[i]]*(1-tp[i])); 
			}
		}
		
		int ans = 0;
		for(int i = sum; i >= 1; i--)
		{
			if(dp[i] >= 1-p0)
			{
				ans = i;
				break;
			}  
		}
		printf("%d\n", ans);
	}
	return 0;
}