天天看点

A + B Problem IIA + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 401436    Accepted Submission(s): 77682

Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2 1 2 112233445566778899 998877665544332211  

Sample Output

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110  

Author Ignatius.L  

#include <cstdio>  //高精度加法
#include <algorithm>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    string a,b;
    int c[1500];
    int i,j,r,x,t,k,y;
    cin>>t;
    for(k=1; k<=t; k++)
    {
        cin>>a>>b;
        r=0;
        y=0;
        for(i=a.size()-1,j=b.size()-1; i>=0&&j>=0; i--,j--)
        {
            x=(a[i]-'0')+(b[j]-'0')+r;
            r=x/10;
            c[y++]=x%10;
        }
        while(i>=0)
        {
            x=(a[i]-'0')+r;
            r=x/10;
            c[y++]=x%10;
            i--;
        }
        while(j>=0)
        {
            x=(b[j]-'0')+r;
            r=x/10;
            c[y++]=x%10;
            j--;
        }
        if(r)
            c[y++]=r;
        for(i=y-1; i>=0; i--)   //去掉前导0
        {
            if(c[i])
                break;
        }
        printf("Case %d:\n",k);
        cout<<a<<" + "<<b<<" = ";
        for(j=i; j>=0; j--)
            printf("%d",c[j]);
        printf("\n");
        if(k!=t)
            printf("\n");
    }
}