Superlong sums
Time Limit: 2000MS | Memory Limit: 65536K |
Total Submissions: 21539 | Accepted: 6316 |
Description
The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.
Input
The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.
Output
Output file should contain exactly N digits in a single line representing the sum of these two integers.
Sample Input
4
0 4
4 2
6 8
3 7
Sample Output
4750
Hint
Huge input,scanf is recommended.
Source
Ural State University collegiate programming contest 2000
#include <stdio.h>
char a[1000001];
int main(){
int i,b,carry,n;
scanf("%d\n",&n);
for(i=0;i<n;i++){
scanf("%d%d",&a[i],&b);
a[i]+=b;
}
for(carry=0;i--;){
a[i]+=carry;
if(a[i]>9){
carry=1;
a[i]%=10;
}
else{
carry=0;
}
a[i]+='0';
}
puts(a);
}