Soundex
Time Limit:1000MS Memory Limit:65536K
Total Submit:2790 Accepted:1450
Description
Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding.
Soundex coding involves translating each word into a series of digits in which each digit represents a letter:
Input
Each line of input contains a single word, all upper case, less than 20 letters long.
Output
For each line of input, produce a line of output giving the Soundex code.
Sample Input
Sample Output
Source
Waterloo local 1999.09.25
#include < iostream >
#include < string >
using namespace std;
int a[ 26 ] = ... {-1,1,2,3,-1,1,2,-1,-1,
2,2,4,5,5,-1,1,
2,6,2,3,-1,1,-1,
2,-1,2} ;
int main()
... {
string str,out;
int i,k;
while(cin>>str)
...{
out="";
int len=str.length();
for(i=0;i<len;i++)
...{
k=a[str[i]-'A'];
if(k==-1)continue;
if(i>0&&k==a[str[i-1]-'A'])
continue;
out+=(k+'0');
}
cout<<out<<endl;
}
return 0;
}
25
1236
11
KHAWN
PFISTER
BOBBY
1 represents B, F, P, or V
2 represents C, G, J, K, Q, S, X, or Z
3 represents D or T
4 represents L
5 represents M or N
6 represents R
The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.