Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
#include<stdio.h>
#include<string.h>
int a[33000],c[16000]; //a记录x轴位置的个数 c记录这个位置上 (前面能包含多少个节点)
int lowbit(int t)
{
return t&( t^(t-1) );
}
int Sum(int pos )
{
int sum=0;
while(pos>0)
{
sum+=a[pos];
pos-=lowbit(pos);
}
return sum+a[0]; //特意加了0的情况
}
void plus(int pos)
{
if( pos==0 ) { a[0]+=1;return;} //特意记录的0的值
while(pos<32900)
{
a[pos]+=1;
pos+=lowbit(pos);
}
}
int main()
{
int n,x,y,temp,i;
while(scanf("%d",&n)!=EOF)
{
int edge=n;
memset( a, 0, sizeof(a) );
memset( c, 0, sizeof(c) );
while(edge--)
{
scanf("%d %d",&x,&y);
temp=Sum(x);
c[temp]+=1;
plus(x);
}
for(i=0;i<n;i++)
printf("%d\n",c[i]);
}
}
下面是羽哥写的向后退一位的代码:
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
//int a[1500];
int tree[32010];
int sum=0;
int other[32010];
int n;
inline int yu(int m){
return m&(-m);
}
void getsum(int b){
sum=0;
int temp2=b;
while(temp2>0){
sum+=tree[temp2];
temp2-=yu(temp2);
}
other[sum]++;
}
void addx(int x){
int temp1=x;
while(temp1<32005){
tree[temp1]+=1;
temp1+=yu(temp1);
}
}
int main(){
while(cin>>n){
memset(tree,0,sizeof(tree));
memset(other,0,sizeof(other));
int m1,m2;
for(int i=1;i<=n;i++){
// cin>>m1>>m2;
scanf("%d%d",&m1,&m2);
getsum(m1+1);
addx(m1+1);
}
for(int h=0;h<n;h++){
printf("%d\n",other[h]);
// cout<<other[h]<<endl;
}
}
// system("pause");
return 0;
}