天天看点

【HUSTOJ】1088: 查找“支撑数”

1088: 查找“支撑数”

Time Limit: 1 Sec   Memory Limit: 128 MB

Submit: 49   Solved: 18

原题链接

Description

在已知一组整数中,有这样一种数非常怪,它们不在第一个,也不在最后一个,而且刚好都比左边和右边相邻的数大,你能找到它们吗?

Input

第一行为整数m,表示输入的整数个数。( 3<= m <=100 ) 第二行为m个整数。

Output

若干个支撑数,每行五个,每个数后面一个空格。

Sample Input

30
5 89 32 31 45 44 12 35 21 34 21 89 43 21 35 22 15 17 1 23 37 21 35 34 21 36 22 45 78 89
      

Sample Output

89 45 35 34 89 
35 17 37 35 36 
      

HINT

Source

#include<iostream>
using namespace std;
main()
{
	int m,a[100],count=0;
	
	cin>>m;
	
	for(int i=0;i<m;i++)
	{
		cin>>a[i];
	}
	for(int k=1;k<m-1;k++)
	{
        if(a[k]>a[k-1]&&a[k]>a[k+1])
		{
	    cout<<a[k]<<' ';
		count++;
		
		if(count==5)
		{count=0;
		 cout<<endl;
	    }
	    }
    }
}