天天看点

HDU 1024 Max Sum Plus PlusMax Sum Plus Plus

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1024

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21926    Accepted Submission(s): 7342

Problem Description Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^  

Input Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.

Process to the end of file.  

Output Output the maximal summation described above in one line.  

Sample Input 1 3 1 2 3 2 6 -1 4 -2 3 -2 3  

Sample Output 6 8 Hint Huge input, scanf and dynamic programming is recommended.  

Author JGShining(极光炫影)   题意:输入m,n,然后输入n个数。求最大连续m段和。  

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>

using namespace std;

const int oo = 0x7fffffff;
int a[1000005];
int dp[1000005];
int Max[1000005];

int main()
{
    int m,n;
    while(~scanf("%d%d", &m, &n))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &a[i]);
            Max[i] = 0;
            dp[i] = 0;
        }
        int M;
        dp[0] = 0;
        Max[0] = 0;
        for(int i=1; i<=m; i++)
        {
            M = -oo;
            for(int j=i; j<=n; j++)
            {
                dp[j] = max(dp[j-1]+a[j], Max[j-1]+a[j]);//其中dp[j-1]表示的是以j-1结尾的元素i个子段的数和,Max[j-1]表示的是前j-1个元素中i-1个子段的数和
                Max[j-1] = M;//更新Max数组,下次循环用到。放在此处是为了实现Max[j-1]+a[j]中a[j]是一个独立的子段,那么此时就应该用的是i-1段
                M = max(dp[j], M);//更新M
            }
        }
        printf("%d\n",M);
    }

    return 0;
}      

转载于:https://www.cnblogs.com/mengzhong/p/5058186.html