天天看点

akoj-1125-小写字母变为大写字母

小写字母变为大写字母

Time Limit:2000MS  Memory Limit:65536K

Total Submit:149 Accepted:114

Description

写一个程序把一个字符串(可能含有空格,长度最长不超过1000) 

中的小写字母转化为大写字母。

Input

输入只有一行,可以包含数字大小写字母

Output

同样是一串字符串,只是将输入串中的小写字母转换成大写输出,其他不变

Sample Input

样例输入:
abcABC  abcxyz123      

Sample Output

样例输出:
ABCABC  ABCXYZ123      
//我在看c++头文件,就运用随便A的
      
#include <stdio.h>
#include <ctype.h>
#include <string.h>
#include <iostream>
using namespace std;
int main(void)
{
    char a[1001],len;
    int i,n;
    gets(a);
    //cin>>a;   输入就有问题,scanf也不行
    len=strlen(a);
    for(i=0; i<len; i++)
    {
        //if(a[i]<='z'&&a[i]>='a') a[i]=a[i]-32;    也可
        if(islower(a[i]))
            a[i]=toupper(a[i]);
        cout<<a[i];
    }
    cout<<endl;
    return 0;
}