天天看点

joj 1270

1270: Triangle Wave

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
joj 1270
3s 8192K 1339 684 Standard

In this problem you are to generate a triangular wave form according to a specified pair of Amplitude and Frequency.

Input and Output

The input will contain two integers, each on a separate line. The first integer is the Amplitude; the second integer is the Frequency.

For the output of your program, you will be printing wave forms each separated by a blank line. The total number of wave forms equals the Frequency, and the horizontal ``height'' of each wave equals the Amplitude. The Amplitude will never be greater than nine.

The waveform itself should be filled with integers on each line which indicate the ``height'' of that line.

NOTE: There is a blank line after each separate waveform, excluding the last one.

Sample Input

3
2      

Sample Output

1
22
333
22
1

1
22
333
22
1      

 #include<cstdio>

void out(int n)

{

 int i,j;

    for(i=1;i<=n;i++)

    {

        for(j=1;j<=i;j++)printf("%d",i);

        printf("\n");

    }

    for(i=n-1;i>=1;i--)

    {

        for(j=1;j<=i;j++)printf("%d",i);

        printf("\n");

    }

}

int main()

{

    int m,n,i;

    scanf("%d%d",&m,&n);

    for(i=0;i<n;i++)

    {

        if(i!=0)printf("\n");

        out(m);

    }

    return 0;

}

上一篇: 2252: Pick Balls
下一篇: ZOJ-1005-Jugs