To The Max
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16851 Accepted Submission(s): 7695
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1081
题目大意:求最大的子矩阵和
solution:将一维数组的最大连续和的思想用到此处、将二维数组一维化
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n, arr[101][101], sum[101], maxi;
while (scanf("%d", &n) != EOF){
for (int i = 1; i <= n; ++i){
for (int j = 1; j <= n; ++j){
scanf("%d", &arr[i][j]);
arr[i][j] += arr[i - 1][j];//矩阵一维化
}
}
maxi = arr[1][1];
for (int i = 0; i < n; ++i){
for (int j = i + 1; j <= n; ++j){
memset(sum, 0, sizeof sum);
for (int k = 1; k <= n; ++k){
if (sum[k - 1] >= 0)sum[k] = sum[k - 1] + arr[j][k] - arr[i][k];//第k列中第i+1行到第j行的行
else sum[k] = arr[j][k] - arr[i][k];
maxi = max(maxi, sum[k]);
}
}
}
printf("%d\n", maxi);
}
return 0;
}