天天看点

PAT Advanced 1009 Product of Polynomials

1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5   
           

Sample Output:

3 3 3.6 2 6.0 1 1.6
           

解题思路

类似于 1002 模拟多项式的乘法计算,

exp

表示指数对应的系数,同样地,

ans

表示相乘完指数对应的系数。

解题代码

#include <cstdio>
#include <iostream>
using namespace std;
const int N = 2010;
double exp[N], ans[N] , b;
int n, m, a, cnt;
int main(){
    scanf("%d", &n);
    for (int i = 0; i < n; i++){
        scanf("%d %lf", &a, &b);
        exp[a] = b;
    }
    scanf("%d", &m);
    for (int i = 0; i < m; i++){
        scanf("%d %lf", &a, &b);
        for (int j = 0; j < N; j++)
            ans[a + j] += exp[j] * b;
    }
    for (int i = 0; i < N; i++)
        if (ans[i] != 0) cnt++;
    printf("%d", cnt);
    for (int i = N; i >= 0; i--)
        if (ans[i] != 0)
            printf(" %d %.1f", i, ans[i]);
    return 0;
}
           

继续阅读