Roadblocks
Description Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path. The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N. The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path). Input Line 1: Two space-separated integers: N and R Lines 2.. R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000) Output Line 1: The length of the second shortest path between node 1 and node N Sample Input Sample Output Hint Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450) Source USACO 2006 November Gold |
题意:求1到n的次短路
保留每一个节点的最短路和次短路,最后输出次短路的结果
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <utility>
using namespace std;
typedef pair<int, int> pii;
const int N = 2e5+10;
const int INF = 0x3f3f3f3f;
int n,m,x,y,z,dis[N][2];
int ft[N],nt[N],u[N],cost[N],sz;
struct cmp{
bool operator () (pii a,pii b){
return a.second > b.second;
}
};
void dij(){
priority_queue<pii,vector<pii>,cmp>q;
memset(dis,INF,sizeof dis);
dis[1][0] = 0;
q.push(make_pair(1, 0));
while(!q.empty()){
pii st = q.top(); q.pop();
int d = st.second, now = st.first;
if(d>dis[now][1]) continue;
for(int i=ft[now];;i=nt[i]){
int dist = d + cost[i];
if(dist<dis[u[i]][0]){
int temp = dis[u[i]][0];
dis[u[i]][0] = dist;
dis[u[i]][1] = temp;
q.push(make_pair(u[i], dist));
}else if(dist<dis[u[i]][1]&&dist!=dis[u[i]][0]){
dis[u[i]][1] = dist;
q.push(make_pair(u[i], dist));
}
if(nt[i]==-1) break;
}
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF){
sz = 0;
memset(ft,-1,sizeof ft);
for(int i=0;i<m;i++){
scanf("%d%d%d",&x,&y,&z);
u[sz] = y; cost[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
u[sz] = x; cost[sz] = z; nt[sz] = ft[y]; ft[y] = sz++;
}
dij();
printf("%d\n",dis[n][1]);
}
return 0;
}