Description
艾利斯顿商学院篮球队要参加一年一度的市篮球比赛了。拉拉队是篮球比赛的一个看点,好的拉拉队往往能帮助球队增加士气,赢得最终的比赛。所以作为拉拉队队长的楚雨荨同学知道,帮助篮球队训练好拉拉队有多么的重要。拉拉队的选拔工作已经结束,在雨荨和校长的挑选下,n位集优秀的身材、舞技于一体的美女从众多报名的女生中脱颖而出。这些女生将随着篮球队的小伙子们一起,和对手抗衡,为艾利斯顿篮球队加油助威。一个阳光明媚的早晨,雨荨带领拉拉队的队员们开始了排练。n个女生从左到右排成一行,每个人手中都举了一个写有26个小写字母中的某一个的牌子,在比赛的时候挥舞,为小伙子们呐喊、加油。雨荨发现,如果连续的一段女生,有奇数个,并且他们手中的牌子所写的字母,从左到右和从右到左读起来一样,那么这一段女生就被称作和谐小群体。现在雨荨想找出所有和谐小群体,并且按照女生的个数降序排序之后,前K个和谐小群体的女生个数的乘积是多少。由于答案可能很大,雨荨只要你告诉她,答案除以19930726的余数是多少就行了。
Input
输入为标准输入。第一行为两个正整数n和K,代表的东西在题目描述中已经叙述。接下来一行为n个字符,代表从左到右女生拿的牌子上写的字母。
Output
输出为标准输出。输出一个整数,代表题目描述中所写的乘积除以19930726的余数,如果总的和谐小群体个数小于K,输出一个整数-1。
Sample Input
5 3
ababa
Sample Output
45
【样例说明】
和谐小群体女生所拿牌子上写的字母从左到右按照女生个数降序排序后为ababa, aba, aba, bab, a, a, a, b, b,前三个长度的乘积为。
Hint
总共20个测试点,数据范围满足:
#pragma comment(linker, "/STACK:102400000,102400000")
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<stack>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 19930726;
const int maxn = 1e6 + 10;
int n;
LL m;
char s[maxn];
struct PalindromicTree
{
const static int maxn = 1e6 + 10;
const static int size = 26;
int next[maxn][size], sz, tot;
int fail[maxn], len[maxn], last;
LL cnt[maxn], c[maxn];
char s[maxn];
void clear()
{
len[1] = -1; len[2] = 0;
fail[1] = fail[2] = 1;
last = (sz = 3) - 1; tot = 0;
memset(next[1], 0, sizeof(next[1]));
memset(next[2], 0, sizeof(next[2]));
}
int Node(int length)
{
memset(next[sz], 0, sizeof(next[sz]));
len[sz] = length; cnt[sz] = 0; return sz++;
}
int getfail(int x)
{
while (s[tot] != s[tot - len[x] - 1]) x = fail[x];
return x;
}
int add(char pos)
{
int x = (s[++tot] = pos) - 'a', y = getfail(last);
if (next[y][x]) { last = next[y][x]; }
else {
last = next[y][x] = Node(len[y] + 2);
fail[last] = len[last] == 1 ? 2 : next[getfail(fail[y])][x];
}
return ++cnt[last];
}
LL get(int x, LL y)
{
LL z = 1;
for (LL i = x; y; y >>= 1)
{
if (y & 1) z = z*i%mod;
i = i*i%mod;
}
return z;
}
void work()
{
LL ans = 1;
for (int i = 1; i <= tot; i++) c[i] = 0;
for (int i = sz-1; i > 2; i--)
{
cnt[fail[i]] += cnt[i];
if (len[i] & 1) c[len[i]] += cnt[i];
}
for (int i = tot; i&&m>0; i--)
{
ans = ans*get(i, min(c[i], m)) % mod;
m -= c[i];
}
if (m > 0) printf("-1\n"); else printf("%lld\n", ans);
}
}solve;
int main()
{
while (scanf("%d%lld%s", &n, &m, s) != EOF)
{
solve.clear();
for (int i = 0; s[i]; i++) solve.add(s[i]);
solve.work();
}
return 0;
}