天天看點

計算兩點間的距離(2001)計算兩點間的距離

計算兩點間的距離

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 95117 Accepted Submission(s): 36532

Problem Description 輸入兩點坐标(X1,Y1),(X2,Y2),計算并輸出兩點間的距離。

Input 輸入資料有多組,每組占一行,由4個實數組成,分别表示x1,y1,x2,y2,資料之間用空格隔開。

Output 對于每組輸入資料,輸出一行,結果保留兩位小數。

Sample Input

0 0 0 1
0 1 1 0
        

Sample Output

1.00
1.41
  
  
   ----------------------------------------------------------
  
  

  
  
   #include <stdio.h>
#include<math.h>
#include <stdlib.h>
int main()
{
    double l,x1,x2,y1,y2;;
    while(scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2)!=EOF){


    l=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
    printf("%.2f\n",l);
    }
    return 0;
}