計算兩點間的距離
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62429 Accepted Submission(s): 23595
Problem Description 輸入兩點坐标(X1,Y1),(X2,Y2),計算并輸出兩點間的距離。
Input 輸入資料有多組,每組占一行,由4個實數組成,分别表示x1,y1,x2,y2,資料之間用空格隔開。
Output 對于每組輸入資料,輸出一行,結果保留兩位小數。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
Author lcy
Source C語言程式設計練習(一)
Recommend JGShining
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double a,b,c,d;
while(cin>>a>>b>>c>>d)
{
double s = sqrt((a-c)*(a-c)+(b-d)*(b-d));
cout.setf(ios::fixed);
cout.precision(2);
cout<<s<<endl;
}
return 0;
}