天天看點

Matrix Swapping II - HDU 2830 dp Matrix Swapping II

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1237    Accepted Submission(s): 824

Problem Description Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output Output one line for each test case, indicating the maximum possible goodness.  

Sample Input

3 4
1011
1001
0001
3 4
1010
1001
0001
        

Sample Output

4
2

Note: Huge Input, scanf() is recommended.
        

題意:交換任意列後,使得1的矩陣面積最大。

思路:還是求最大矩陣面積,隻不過需要排序,具體實作看代碼。

AC代碼如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1010][1010];
int n,m,val[1010][1010],l[1010];
int main()
{ int i,j,k,ans;
  while(~scanf("%d%d",&n,&m))
  { for(i=1;i<=n;i++)
    { scanf("%s",s[i]+1);
      for(j=1;j<=m;j++)
       if(s[i][j]=='1')
        val[i][j]=val[i-1][j]+1;
       else
        val[i][j]=0;
    }
    ans=0;
    for(i=1;i<=n;i++)
    { for(j=1;j<=m;j++)
       l[j]=j;
      sort(val[i]+1,val[i]+1+m);
      val[i][0]=val[i][m+1]=-1;
      for(j=1;j<=n;j++)
       while(val[i][l[j]-1]>=val[i][j])
        l[j]=l[l[j]-1];
      for(j=1;j<=n;j++)
      ans=max(ans,val[i][j]*(m-l[j]+1));
    }
    printf("%d\n",ans);
  }
}