Constructing Roads In JGShining's Kingdom Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status
Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.
Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.
With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.
Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.
The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.
But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.
For example, the roads in Figure I are forbidden.
In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
Sample Output
Case 1:
My king, at most 1 road can be built.
Case 2:
My king, at most 2 roads can be built.
兩個for直接逾時
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
int x,y;
}a[500001];
int num[500001];
int main()
{
int n;
int k=1;
while(~scanf("%lld",&n))
{
int maxm=0;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
num[i]=1;
for(int j=1;j<i;j++)
{
if(a[i].x>a[j].x&&a[i].y>a[j].y)
if(num[i]<=num[j]+1)
num[i]=num[j]+1;
}
maxm=max(maxm,num[i]);
}
printf("Case %d:\n",k++);
if(maxm==1)
printf("My king, at most %d road can be built.\n",maxm);
else
printf("My king, at most %d roads can be built.\n",maxm)
}
return 0;
}
看了别人的,才知道要用二分。╭∩╮(︶︿︶)╭∩╮
詳解:http://blog.csdn.net/lishuhuakai/article/details/8168328 <span style="font-size:14px;">#include<iostream>
using namespace std;
long d[500001],a[500001]; //d[i]用來存最長不降子序列 最後一個元素
long find(long a,long left,long right) //二分查找
{
long mid;
while(left<=right)
{
mid=(left+right)/2;
if(a>d[mid])//偏小
left=mid+1;
else
right=mid-1;
}
return left;
}
int main()
{
long n,i,j,len,p,t,k=0;
while(scanf("%d",&n)!=EOF)
{
k++;
for(i=1;i<=n;i++)
{scanf("%d%d",&j,&p);
a[j]=p;}
d[1]=a[1];
len=1;//初始序列長度
for(i=2;i<=n;i++)
{
t=find(a[i],1,len); //找出a[i]的位置
d[t]=a[i]; //更新d[t],使d[t]盡量是最小的,顯而易見,dp[t]越小,後面的dp[k](k>t)更大的可能性就會越大
//為什麼可以這樣做?仔細觀察,發現對于一個a[i],要判斷它是否是某個不降子序列的元素,我們隻需要拿它和前面的dp[j](j<len)比較即可,
//由于dp[j]記錄的是到a[j]為止的序列的最長不降子序列的最後一個元素,如果a[i]>dp[j]并且a[i].b<dp[j+1],
//那麼我們自然要用a[i]更新dp[j+1](很明顯,最長子序列長度為j+1),而如果a[i]比dp[j]的值都大,
//這說明a[i]可以接在所有的dp[j]後面,自然我們選擇最長的dp[len],是以,加入之後,len的長度要自加1
if(t>len) //因為d[len]都是最大的
len++;
}
if(len==1)
printf("Case %d:\nMy king, at most %d road can be built.\n\n",k,len); //單數
else
printf("Case %d:\nMy king, at most %d roads can be built.\n\n",k,len); //複數
}
return 0;
}</span>