最近剛學完數值分析上的方程求根——牛頓法,是以做幾題練習一下。
Problem Description Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input 2 100 200
Sample Output -74.4291 -178.8534 題解:此題與2199題解題方法一樣,就是2199的變形,都是用牛頓疊代法,也可以用其他方法 ,有時間再補上代碼; 與2199的差別就是此題要求導數的根; 用牛頓疊代法解非線性方程f(x)=0,是把非線性方程線性化的一種近似方法。把f(x)在點x0的某鄰域内展開成 泰勒 級數 f(x) = f(x0)+(x-x0)f'(x0)+(x-x0)^2*f''(x0)/2! +… ,取其線性部分(即泰勒展開的前兩項),并令其等于0,即f(x0)+f'(x0)(x-x0)=0 ,以此作為非線性方程f(x) = 0的近似方程,若f'(x0)≠0,則其解為x1=x0-f(x0)/f'(x0), 這樣,得到牛頓疊代法的一個疊代關系式:x(n+1)=x(n)-f(x(n))/f'(x(n))。
注意: 1處:把x1-x0作為結束的條件; 2處:k=0(表示傳回值是沒有方程的根),而若題目在k=0.0出滿足題目要求,最好把return 0;改為return -1; 3處:需要把0到100内的數都看作標明的初始近似值: 代碼實作:
#include<stdio.h>
#include<math.h>
#include<cstring>
#define g(x) 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x
#define f(x) 42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x-y
#define f1(x) 42*6*x*x*x*x*x+48*5*x*x*x*x+42*x+10
/*原函數F(x)=g(x),f(x)為F(x)的導數,f1(x)為F(x)的二階導數;因為在x取0到100之間必有一個解,是以導數f(x)=0,即為方程的最小值,包括端點0和100。*/
using namespace std;
#pragma comment(linker,"/STACK:102400000,102400000")
double y;
double Newton_iteration(double x)
{
int k=1;
while(fabs(f(x))>1e-6)//……1
{
x=x-(f(x))/(f1(x));
k++;
if(k>30)
//超過預定次數,則方法失敗;
return -1;
}
return x;
}
int main()
{
//freopen("input.txt","r",stdin);
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
int flag=0;
double z;
for(double x=0.0;x<=100;x++)//……3
{
z=Newton_iteration(x);
if(z<=100.0&&z>=0.0)//……2
{
flag=1;
break;
}
}
if(flag==0)
printf("No solution!\n");//此處對題目沒有影響,可以删除
else
printf("%.4lf\n",g(z));
}
return 0;
}