Problem Description
給出一個數列的遞推公式,希望你能計算出該數列的第N個數。遞推公式如下:
F(n)=F(n-1)+F(n-2)-F(n-3). 其中,F(1)=2, F(2)=3, F(3)=5.
很熟悉吧,可它貌似真的不是斐波那契數列呢,你能計算出來嗎?
Input
輸入隻有一個正整數N(N>=4).
Output
輸出隻有一個整數F(N).
Example Input
5
Example Output
8
#include<stdio.h>
int F(int n);
int main()
{
int y,N;
scanf("%d",&N);
y=F(N);
printf("%d\n",y);
return 0;
}
int F(int n)
{
int f,f1=2,f2=3,f3=5,i;
for(i=4;i<=n;i++)
{
f=f3+f2-f1;
f1=f2;
f2=f3;
f3=f;
}
return f;
}