1001. A+B Format (20)
时间限制 400 ms
内存限制 32000 kB
代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9
Sample Output
-999,991
这个比较简单:
#include <iostream>
#include <string>
#include <stack>
#include <cmath>
using namespace std;
int main()
{
int A,B;
stack<int> s;
while(cin>>A>>B)
{
int sum=A+B;
int flag=(sum>=0?true:false);
sum=abs(sum);
if(sum==0)
{
cout<<"0"<<endl;
break;
}
while(sum>0)
{
int temp=sum%10;
s.push(temp);
sum=sum/10;
}
int length=s.size();
int point=length%3;
if(!flag)
{
cout<<"-";
}
int k=0;
while(s.size()!=0)
{
k++;
cout<<s.top();
s.pop();
if((abs(k-point))%3==0&&k!=length)
{
cout<<",";
}
}
cout<<endl;
}
return 0;
}