Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3
Source Greater New York 2000
Recommend We have carefully selected several similar problems for you: 1017 1016 1019 1014 1010 题意:本题要求的是给出一个整数,求该整数的各位数字之和; 分析:本题需注意的是,体重并没给出整数的位数,故需要很容易想到字符数组,然后用一循环即可解出; 代码:
#include<stdio.h>
#include<string.h>
int fun(int n)
{
int num=0,t,s;
while(n!=0)
{
t=n%10;
num+=t;
n=n/10;
}
return num;
}
int main()
{
int m,i,j,p;
int sum;
int a[100000];
char a1[100000];
while(~scanf("%s",a1))
{
if(strcmp(a1,"0")==0)
break;
p=strlen(a1);
for(i=0,j=p-1;j>=0;i++,j--)
a[j]=a1[i]-'0';
for(i=0,sum=0;i<p;i++)
sum+=a[i];
while(1)
{
m=fun(sum);
if(m<10)
break;
sum=m;
}
printf("%d\n",m);
}
return 0;
}