How many prime numbers
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7656 Accepted Submission(s): 2563
Problem Description Give you a lot of positive integers, just to find out how many prime numbers there are.
Input There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
Output For each case, print the number of prime numbers you have found out.
Sample Input
3
2 3 4
Sample Output
2
Author wangye
Source HDU 2007-11 Programming Contest_WarmUp
Recommend 威士忌
#include <stdio.h>
#include <math.h>
int isPrime(int n)
{
int i, l = sqrt(n);
for(i = 2; i <= l; i++)
if(n % i == 0)
return 0;
return 1;
}
int main()
{
int n, num, acount;
while(~scanf("%d", &n))
{
acount = 0;
while(n--)
{
scanf("%d", &num);
if(isPrime(num))
acount++;
}
printf("%d\n", acount);
}
return 0;
}