Max Num
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9629 Accepted Submission(s): 6123
Problem Description There are some students in a class, Can you help teacher find the highest student .
Input There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
Output For each case output the highest height, the height to two decimal plases;
Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00
Sample Output
180.00
182.00
Author Lily
Source 浙江工业大学网络选拔赛
Recommend linle
#include <stdio.h>
int main()
{
int t, n;
double h, maxh;
scanf("%d", &t);
while(t--)
{
scanf("%d", &n);
scanf("%lf", &h);
maxh = h;
n--;
while(n--)
{
scanf("%lf", &h);
if(maxh < h)
maxh = h;
}
printf("%.2lf\n", maxh);
}
return 0;
}