分糖果
Time Limit:1000MS Memory Limit:65536K
Total Submit:401 Accepted:197
Description
暑假了小明在家里闲着无事,就帮着自己的弟弟辅导功课。一天,弟弟问了小明这样一个问题:老师手上有n个糖果,要奖励班上的优秀同学。为公平起见,被奖励的同学每人的糖果数是一样的。假如奖励前5名同学,则还多1枚糖果;假如奖励前7个同学,则还剩3枚糖果。问老师手上最少有几枚糖果?小明很快帮弟弟的问题解决了。但喜欢编程的小明心想,类似这样的问题,编程求解不是更快吗?!请你乘小明还在思考的时候,捷足先登,提交解答代码。
Input
输入包含多组测试数据。每组数据包含4个整数,分别为a1,b1,a2,b2,表示老师奖励前a1个同学,还剩b1枚糖果没分出去,或者奖励前a1个同学,还剩b1枚糖果没分出去。(a1>b1>0,a2>b2>0)且(a1≠a2,a1,a2<1000)。
Output
对于每组测试数据,输出一个正整数,即老师手上最少应该有的糖果数。
Sample Input
5 1 7 3
3 2 11 3
Sample Output
31
14
Source
[email protected]
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1013 {
class Program {
static int gcd(int a, int b) {
return b == 0 ? a : gcd(b, a % b);
}
static int lcm(int a, int b) {
return a / gcd(a, b) * b;
}
static void Main(string[] args) {
string s;
while ((s = Console.ReadLine()) != null) {
string[] a = s.Split();
int a1 = int.Parse(a[0]), b1 = int.Parse(a[1]), a2 = int.Parse(a[2]), b2 = int.Parse(a[3]);
for (int i = 1; i <= lcm(a1, a2); i++)//实际这样写我感觉是不合理的,但是AC了,怎么能求最小公倍数呢,i don't know!
if (i % a1 == b1 && i % a2 == b2) { Console.WriteLine(i); break; }
}
}
}
}